今天安装了vue cli 3,使用命令时报:

You are using Node v8.4.0, but this version of vue-cli requires Node >=8.9.
Please upgrade your Node version.

然后再用node -v,发现在本地的node版本是v8.4.0,有点老了,要升级了。

可是,node怎么升级呢?有点慌。

npm install,肯定不可以啊,环境包含包着包啊!!

用node境像吧,第一次就是用它,这次肯定也可以。但这。。。,有些野蛮,

不像是程序员的追求。

这不行,那野蛮,百度吧(就这点本事了!!!)

果然,找到一篇轻松两步完成Node.js版本升级

首先,你得用npm全局安装一个管理node版本的管理模板n,对就是n,不用怀疑,github地址https://github.com/tj/n

安装命令

npm i -g n

但我的电脑却报错了
报错了

我勒个去,这错报的,继续百度,又一篇npm install -g n 运行错误

将安装命令修改为

npm i -g n --force

一切ok!

下一步,升级node版本

管理板块n的命令有很多

  1. 升级到指定的版本

    n 版本号 如 n 10.0.0
  2. 列表项目

    n latest
  3. 安装最近的稳定版本

    n stable

作为一个开发者,我选择了稳定版本(我怕啊)

来看看效果
运行效果

报错了,百度再查,github上说用n --stable就可以执行,那就再来
请输入图片描述

好像成功了,但感觉不对啊,执行node -v
请输入图片描述

还是之前那个版本,我。。。,继续百度,直到我看到这篇文章windows下更新Node

我知道我错了

原来n模块是不支持window系统,window系统升级node就只有到node官网下载window安装包来覆盖之前的Node